CVE-2018-12293

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The getImageData function in the ImageBufferCairo class in WebCore/platform/graphics/cairo/ImageBufferCairo.cpp in WebKit, as used in WebKitGTK+ prior to version 2.20.3 and WPE WebKit prior to version 2.20.1, is vulnerable to a heap-based buffer overflow triggered by an integer overflow, which could be abused by crafted HTML content.

References

http://packetstormsecurity.com/files/148200/WebKitGTK-Data-Leak-Code-Execution.html

http://www.openwall.com/lists/oss-security/2018/06/14/1

http://www.securityfocus.com/archive/1/542087/100/0/threaded

https://bugs.webkit.org/show_bug.cgi?id=186384

https://security.gentoo.org/glsa/201808-04

https://trac.webkit.org/changeset/232618

https://usn.ubuntu.com/3687-1/

https://www.exploit-db.com/exploits/45205/

Details

Source: MITRE

Published: 2018-06-19

Updated: 2020-08-24

Type: CWE-787

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH

Tenable Plugins

View all (2 total)

IDNameProductFamilySeverity
112078GLSA-201808-04 : WebkitGTK+: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
110611Ubuntu 16.04 LTS / 17.10 / 18.04 LTS : WebKitGTK+ vulnerabilities (USN-3687-1)NessusUbuntu Local Security Checks
high