CVE-2018-1125

MEDIUM

Description

procps-ng before version 3.3.15 is vulnerable to a stack buffer overflow in pgrep. This vulnerability is mitigated by FORTIFY, as it involves strncat() to a stack-allocated string. When pgrep is compiled with FORTIFY (as on Red Hat Enterprise Linux and Fedora), the impact is limited to a crash.

References

http://seclists.org/oss-sec/2018/q2/122

http://www.securityfocus.com/bid/104214

https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1125

https://lists.debian.org/debian-lts-announce/2018/05/msg00021.html

https://usn.ubuntu.com/3658-1/

https://usn.ubuntu.com/3658-3/

https://www.debian.org/security/2018/dsa-4208

https://www.qualys.com/2018/05/17/procps-ng-audit-report-advisory.txt

Details

Source: MITRE

Published: 2018-05-23

Updated: 2019-03-27

Type: CWE-119

Risk Information

CVSS v2.0

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH