CVE-2018-1093

MEDIUM
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The ext4_valid_block_bitmap function in fs/ext4/balloc.c in the Linux kernel through 4.15.15 allows attackers to cause a denial of service (out-of-bounds read and system crash) via a crafted ext4 image because balloc.c and ialloc.c do not validate bitmap block numbers.

References

http://openwall.com/lists/oss-security/2018/03/29/1

https://bugzilla.kernel.org/show_bug.cgi?id=199181

https://bugzilla.redhat.com/show_bug.cgi?id=1560782

https://git.kernel.org/pub/scm/linux/kernel/git/tytso/ext4.git/commit/?id=7dac4a1726a9c64a517d595c40e95e2d0d135f6f

https://lists.debian.org/debian-lts-announce/2018/06/msg00000.html

https://lists.debian.org/debian-lts-announce/2018/07/msg00015.html

https://lists.debian.org/debian-lts-announce/2018/07/msg00016.html

https://usn.ubuntu.com/3676-1/

https://usn.ubuntu.com/3676-2/

https://usn.ubuntu.com/3752-1/

https://usn.ubuntu.com/3752-2/

https://usn.ubuntu.com/3752-3/

https://usn.ubuntu.com/3754-1/

https://www.debian.org/security/2018/dsa-4188

Details

Source: MITRE

Published: 2018-04-02

Updated: 2018-08-29

Type: CWE-125

Risk Information

CVSS v2

Base Score: 7.1

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:C

Impact Score: 6.9

Exploitability Score: 8.6

Severity: HIGH

CVSS v3

Base Score: 5.5

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 1.8

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* versions up to 4.15.15 (inclusive)

Tenable Plugins

View all (29 total)

IDNameProductFamilySeverity
141697EulerOS Virtualization 3.0.2.2 : kernel (EulerOS-SA-2020-2222)NessusHuawei Local Security Checks
high
129261EulerOS 2.0 SP3 : kernel (EulerOS-SA-2019-2068)NessusHuawei Local Security Checks
high
126266EulerOS 2.0 SP2 : kernel (EulerOS-SA-2019-1639)NessusHuawei Local Security Checks
high
124814EulerOS Virtualization for ARM 64 3.0.1.0 : kernel (EulerOS-SA-2019-1490)NessusHuawei Local Security Checks
medium
123226openSUSE Security Update : the Linux Kernel (openSUSE-2019-536) (Spectre)NessusSuSE Local Security Checks
high
121945Photon OS 2.0: Linux PHSA-2018-2.0-0043NessusPhotonOS Local Security Checks
medium
121840Photon OS 1.0: Linux PHSA-2018-1.0-0134NessusPhotonOS Local Security Checks
medium
120067SUSE SLED15 / SLES15 Security Update : kernel (SUSE-SU-2018:2092-1) (Spectre)NessusSuSE Local Security Checks
high
118272SUSE SLES12 Security Update : kernel (SUSE-SU-2018:1855-2)NessusSuSE Local Security Checks
high
112189Ubuntu 16.04 LTS / 18.04 LTS : Linux kernel (Azure, GCP, OEM) vulnerabilities (USN-3752-3)NessusUbuntu Local Security Checks
high
112113Ubuntu 14.04 LTS : Linux kernel vulnerabilities (USN-3754-1)NessusUbuntu Local Security Checks
critical
112110Ubuntu 16.04 LTS : Linux kernel (HWE) vulnerabilities (USN-3752-2)NessusUbuntu Local Security Checks
high
112109Ubuntu 18.04 LTS : Linux kernel vulnerabilities (USN-3752-1)NessusUbuntu Local Security Checks
high
111936Photon OS 1.0: Linux PHSA-2018-1.0-0134 (deprecated)NessusPhotonOS Local Security Checks
medium
111414openSUSE Security Update : the Linux Kernel (openSUSE-2018-762) (Spectre)NessusSuSE Local Security Checks
high
111302Photon OS 2.0 : linux-esx / linux / linux-secure / linux-aws (PhotonOS-PHSA-2018-2.0-0043) (deprecated)NessusPhotonOS Local Security Checks
medium
111082Debian DLA-1422-2 : linux security update (Spectre)NessusDebian Local Security Checks
high
110838SUSE SLES12 Security Update : kernel (SUSE-SU-2018:1855-1)NessusSuSE Local Security Checks
high
110658openSUSE Security Update : the Linux Kernel (openSUSE-2018-656) (Spectre)NessusSuSE Local Security Checks
high
110637SUSE SLES12 Security Update : kernel (SUSE-SU-2018:1762-1)NessusSuSE Local Security Checks
high
110636SUSE SLES12 Security Update : kernel (SUSE-SU-2018:1761-1)NessusSuSE Local Security Checks
high
110477Ubuntu 14.04 LTS : Linux kernel (Xenial HWE) vulnerabilities (USN-3676-2)NessusUbuntu Local Security Checks
medium
110476Ubuntu 16.04 LTS : Linux kernel vulnerabilities (USN-3676-1)NessusUbuntu Local Security Checks
medium
110314Debian DLA-1392-1 : linux security updateNessusDebian Local Security Checks
high
109881Oracle Linux 6 : Unbreakable Enterprise kernel (ELSA-2018-4110) (Meltdown) (Spectre)NessusOracle Linux Local Security Checks
high
109829Oracle Linux 6 / 7 : Unbreakable Enterprise kernel (ELSA-2018-4109) (Meltdown) (Spectre)NessusOracle Linux Local Security Checks
high
109518Debian DSA-4188-1 : linux - security update (Spectre)NessusDebian Local Security Checks
high
109426OracleVM 3.4 : Unbreakable / etc (OVMSA-2018-0037)NessusOracleVM Local Security Checks
high
109386Oracle Linux 6 / 7 : Unbreakable Enterprise kernel (ELSA-2018-4084)NessusOracle Linux Local Security Checks
high