CVE-2018-1000861

CRITICAL
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153 and earlier, LTS 2.138.3 and earlier in stapler/core/src/main/java/org/kohsuke/stapler/MetaClass.java that allows attackers to invoke some methods on Java objects by accessing crafted URLs that were not intended to be invoked this way.

References

http://www.securityfocus.com/bid/106176

https://access.redhat.com/errata/RHBA-2019:0024

https://jenkins.io/security/advisory/2018-12-05/#SECURITY-595

Details

Source: MITRE

Published: 2018-12-10

Updated: 2019-05-08

Type: CWE-502

Risk Information

CVSS v2

Base Score: 10

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* versions up to 2.138.3 (inclusive)

cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:* versions up to 2.153 (inclusive)

Configuration 2

OR

cpe:2.3:a:redhat:openshift_container_platform:3.11:*:*:*:*:*:*:*

Tenable Plugins

View all (1 total)

IDNameProductFamilySeverity
119500Jenkins < 2.138.4 LTS / 2.150.1 LTS / 2.154 Multiple VulnerabilitiesNessusCGI abuses
critical