CVE-2018-1000858

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

GnuPG version 2.1.12 - 2.2.11 contains a Cross ite Request Forgery (CSRF) vulnerability in dirmngr that can result in Attacker controlled CSRF, Information Disclosure, DoS. This attack appear to be exploitable via Victim must perform a WKD request, e.g. enter an email address in the composer window of Thunderbird/Enigmail. This vulnerability appears to have been fixed in after commit 4a4bb874f63741026bd26264c43bb32b1099f060.

References

https://sektioneins.de/en/advisories/advisory-012018-gnupg-wkd.html

https://sektioneins.de/en/blog/18-11-23-gnupg-wkd.html

https://usn.ubuntu.com/3853-1/

Details

Source: MITRE

Published: 2018-12-20

Updated: 2019-02-13

Type: CWE-352

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:gnupg:gnupg:*:*:*:*:*:*:*:* versions from 2.1.12 to 2.2.11 (inclusive)

Configuration 2

OR

cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*

cpe:2.3:o:canonical:ubuntu_linux:18.10:*:*:*:*:*:*:*

Tenable Plugins

View all (8 total)

IDNameProductFamilySeverity
131514EulerOS Virtualization for ARM 64 3.0.3.0 : gnupg2 (EulerOS-SA-2019-2349)NessusHuawei Local Security Checks
high
128153Photon OS 3.0: Gnupg PHSA-2019-3.0-0024NessusPhotonOS Local Security Checks
high
126197Photon OS 1.0: Gnupg PHSA-2019-1.0-0237NessusPhotonOS Local Security Checks
high
121270Fedora 28 : gnupg2 (2019-e70c729d8a)NessusFedora Local Security Checks
high
121148openSUSE Security Update : gpg2 (openSUSE-2019-20)NessusSuSE Local Security Checks
high
121140Fedora 29 : gnupg2 (2019-75a8da28f0)NessusFedora Local Security Checks
high
121095Ubuntu 18.04 LTS / 18.10 : GnuPG vulnerability (USN-3853-1)NessusUbuntu Local Security Checks
high
121003SUSE SLED15 / SLES15 Security Update : gpg2 (SUSE-SU-2019:0023-1)NessusSuSE Local Security Checks
high