CVE-2018-1000225

MEDIUM

Description

Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection suggests at least 2.0.0+ or possibly even older versions may be vulnerable contains a Cross Site Scripting (XSS) vulnerability in cobbler-web that can result in Privilege escalation to admin.. This attack appear to be exploitable via "network connectivity". Sending unauthenticated JavaScript payload to the Cobbler XMLRPC API (/cobbler_api).

References

https://github.com/cobbler/cobbler/issues/1917

https://movermeyer.com/2018-08-02-privilege-escalation-exploits-in-cobblers-api/

Details

Source: MITRE

Published: 2018-08-20

Updated: 2018-10-19

Type: CWE-79

Risk Information

CVSS v2.0

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Impact Score: 2.7

Exploitability Score: 2.8

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:cobblerd:cobbler:*:*:*:*:*:*:*:*

Tenable Plugins

View all (2 total)

IDNameProductFamilySeverity
145357openSUSE Security Update : cobbler (openSUSE-2021-46)NessusSuSE Local Security Checks
critical
112266openSUSE Security Update : cobbler (openSUSE-2018-952)NessusSuSE Local Security Checks
high