CVE-2018-1000079

MEDIUM

Description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in gem installation that can result in the gem could write to arbitrary filesystem locations during installation. This attack appear to be exploitable via the victim must install a malicious gem. This vulnerability appears to have been fixed in 2.7.6.

References

http://blog.rubygems.org/2018/02/15/2.7.6-released.html

https://access.redhat.com/errata/RHSA-2018:3729

https://access.redhat.com/errata/RHSA-2018:3730

https://access.redhat.com/errata/RHSA-2018:3731

https://github.com/rubygems/rubygems/commit/666ef793cad42eed96f7aee1cdf77865db921099

https://github.com/rubygems/rubygems/commit/f83f911e19e27cbac1ccce7471d96642241dd759

https://lists.debian.org/debian-lts-announce/2018/07/msg00012.html

https://usn.ubuntu.com/3621-1/

https://www.debian.org/security/2018/dsa-4219

https://www.debian.org/security/2018/dsa-4259

Details

Source: MITRE

Published: 2018-03-13

Updated: 2018-11-30

Type: CWE-22

Risk Information

CVSS v2.0

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 5.5

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

Impact Score: 3.6

Exploitability Score: 1.8

Severity: MEDIUM