CVE-2018-1000076

HIGH

Description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Improper Verification of Cryptographic Signature vulnerability in package.rb that can result in a mis-signed gem could be installed, as the tarball would contain multiple gem signatures.. This vulnerability appears to have been fixed in 2.7.6.

References

http://blog.rubygems.org/2018/02/15/2.7.6-released.html

https://access.redhat.com/errata/RHSA-2018:3729

https://access.redhat.com/errata/RHSA-2018:3730

https://access.redhat.com/errata/RHSA-2018:3731

https://github.com/rubygems/rubygems/commit/f5042b879259b1f1ce95a0c5082622c646376693

https://lists.debian.org/debian-lts-announce/2018/04/msg00000.html

https://lists.debian.org/debian-lts-announce/2018/04/msg00001.html

https://lists.debian.org/debian-lts-announce/2018/04/msg00023.html

https://lists.debian.org/debian-lts-announce/2018/07/msg00012.html

https://usn.ubuntu.com/3621-1/

https://www.debian.org/security/2018/dsa-4219

https://www.debian.org/security/2018/dsa-4259

Details

Source: MITRE

Published: 2018-03-13

Updated: 2018-11-30

Type: CWE-347

Risk Information

CVSS v2.0

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL