CVE-2017-9756

MEDIUM

Description

The aarch64_ext_ldst_reglist function in opcodes/aarch64-dis.c in GNU Binutils 2.28 allows remote attackers to cause a denial of service (buffer overflow and application crash) or possibly have unspecified other impact via a crafted binary file, as demonstrated by mishandling of this file during "objdump -D" execution.

References

http://www.securityfocus.com/bid/99103

https://security.gentoo.org/glsa/201801-01

https://sourceware.org/bugzilla/show_bug.cgi?id=21595

https://www.exploit-db.com/exploits/42204/

Details

Source: MITRE

Published: 2017-06-19

Updated: 2018-01-09

Type: CWE-119

Risk Information

CVSS v2.0

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 1.8

Severity: HIGH