CVE-2017-9500

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

In ImageMagick 7.0.5-8 Q16, an assertion failure was found in the function ResetImageProfileIterator, which allows attackers to cause a denial of service via a crafted file.

References

http://www.securityfocus.com/bid/98941

https://github.com/ImageMagick/ImageMagick/issues/500

https://lists.debian.org/debian-lts-announce/2019/05/msg00015.html

https://www.debian.org/security/2017/dsa-4019

Details

Source: MITRE

Published: 2017-06-07

Updated: 2019-10-03

Type: CWE-617

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 2.8

Severity: MEDIUM

Tenable Plugins

View all (7 total)

IDNameProductFamilySeverity
125093Debian DLA-1785-1 : imagemagick security updateNessusDebian Local Security Checks
critical
108935openSUSE Security Update : ImageMagick (openSUSE-2018-343)NessusSuSE Local Security Checks
critical
108877SUSE SLES11 Security Update : ImageMagick (SUSE-SU-2018:0880-1)NessusSuSE Local Security Checks
high
108824SUSE SLED12 / SLES12 Security Update : ImageMagick (SUSE-SU-2018:0857-1)NessusSuSE Local Security Checks
critical
104403Debian DSA-4019-1 : imagemagick - security updateNessusDebian Local Security Checks
critical
101031Debian DLA-1000-1 : imagemagick security updateNessusDebian Local Security Checks
medium
100847ImageMagick 6.x < 6.9.8-10 / 7.x < 7.0.5-9 Multiple VulnerabilitiesNessusWindows
high