CVE-2017-9229

HIGH
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

An issue was discovered in Oniguruma 6.2.0, as used in Oniguruma-mod in Ruby through 2.4.1 and mbstring in PHP through 7.1.5. A SIGSEGV occurs in left_adjust_char_head() during regular expression compilation. Invalid handling of reg->dmax in forward_search_range() could result in an invalid pointer dereference, normally as an immediate denial-of-service condition.

References

https://access.redhat.com/errata/RHSA-2018:1296

https://github.com/kkos/oniguruma/commit/b690371bbf97794b4a1d3f295d4fb9a8b05d402d

https://github.com/kkos/oniguruma/issues/59

Details

Source: MITRE

Published: 2017-05-24

Updated: 2018-05-04

Type: CWE-476

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:oniguruma_project:oniguruma:6.2.0:*:*:*:*:*:*:*

Configuration 2

OR

cpe:2.3:a:php:php:*:*:*:*:*:oniguruma-mod:*:* versions up to 7.1.5 (inclusive)

cpe:2.3:a:ruby-lang:ruby:*:*:*:*:*:oniguruma-mod:*:* versions up to 2.4.1 (inclusive)

Tenable Plugins

View all (31 total)

IDNameProductFamilySeverity
137599SUSE SLES12 Security Update : ruby2.1 (SUSE-SU-2020:1570-1)NessusSuSE Local Security Checks
high
135605EulerOS Virtualization 3.0.2.2 : ruby (EulerOS-SA-2020-1443)NessusHuawei Local Security Checks
critical
134484EulerOS Virtualization for ARM 64 3.0.2.0 : ruby (EulerOS-SA-2020-1195)NessusHuawei Local Security Checks
critical
132184EulerOS 2.0 SP3 : php (EulerOS-SA-2019-2649)NessusHuawei Local Security Checks
critical
131592EulerOS 2.0 SP2 : php (EulerOS-SA-2019-2438)NessusHuawei Local Security Checks
critical
129184EulerOS 2.0 SP5 : ruby (EulerOS-SA-2019-1990)NessusHuawei Local Security Checks
critical
121702Photon OS 1.0: Ruby PHSA-2017-0021NessusPhotonOS Local Security Checks
critical
98864PHP 7.1.x < 7.1.7 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98844PHP 7.0.x < 7.0.21 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98822PHP 5.6.x < 5.6.31 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
120010SUSE SLES12 Security Update : php5 (SUSE-SU-2017:3277-1)NessusSuSE Local Security Checks
critical
120009SUSE SLES12 Security Update : php7 (SUSE-SU-2017:3237-1)NessusSuSE Local Security Checks
critical
111870Photon OS 1.0: Bindutils / Krb5 / Ruby / Sudo / Zlib PHSA-2017-0021 (deprecated)NessusPhotonOS Local Security Checks
high
105513SUSE SLES11 Security Update : php53 (SUSE-SU-2018:0003-1)NessusSuSE Local Security Checks
critical
105266openSUSE Security Update : php5 (openSUSE-2017-1371)NessusSuSE Local Security Checks
critical
105238openSUSE Security Update : php7 (openSUSE-2017-1353)NessusSuSE Local Security Checks
critical
103121Tenable SecurityCenter PHP < 5.6.31 Multiple Vulnerabilities (TNS-2017-12NessusMisc.
critical
102545Amazon Linux AMI : php56 (ALAS-2017-871)NessusAmazon Linux Local Security Checks
critical
102416Ubuntu 14.04 LTS / 16.04 LTS / 17.04 : php5, php7.0 vulnerabilities (USN-3382-1)NessusUbuntu Local Security Checks
critical
102181Amazon Linux AMI : php70 (ALAS-2017-867)NessusAmazon Linux Local Security Checks
critical
101864Fedora 24 : php (2017-5ade380ab2)NessusFedora Local Security Checks
critical
101797Fedora 26 : php (2017-b8bb4b86e2)NessusFedora Local Security Checks
critical
101745Fedora 26 : oniguruma (2017-ee01a2ced6)NessusFedora Local Security Checks
critical
101538Fedora 25 : php (2017-b674dc22ad)NessusFedora Local Security Checks
critical
101527PHP 7.1.x < 7.1.7 Multiple VulnerabilitiesNessusCGI abuses
critical
101526PHP 7.0.x < 7.0.21 Multiple VulnerabilitiesNessusCGI abuses
critical
101525PHP 5.6.x < 5.6.31 Multiple VulnerabilitiesNessusCGI abuses
critical
101316Slackware 14.0 / 14.1 / 14.2 / current : php (SSA:2017-188-01)NessusSlackware Local Security Checks
critical
100748Fedora 24 : oniguruma (2017-e2d6d0067f)NessusFedora Local Security Checks
critical
100730Fedora 25 : oniguruma (2017-60997f0d14)NessusFedora Local Security Checks
critical
100478Debian DLA-958-1 : libonig security updateNessusDebian Local Security Checks
critical