CVE-2017-8818

HIGH

Description

curl and libcurl before 7.57.0 on 32-bit platforms allow attackers to cause a denial of service (out-of-bounds access and application crash) or possibly have unspecified other impact because too little memory is allocated for interfacing to an SSL library.

References

http://security.cucumberlinux.com/security/details.php?id=163

http://www.securityfocus.com/bid/102014

http://www.securitytracker.com/id/1039898

https://curl.haxx.se/docs/adv_2017-af0a.html

https://security.gentoo.org/glsa/201712-04

Details

Source: MITRE

Published: 2017-11-29

Updated: 2017-12-20

Type: CWE-119

Risk Information

CVSS v2.0

Base Score: 7.5

Vector: (AV:N/AC:L/Au:N/C:P/I:P/A:P)

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL