CVE-2017-8765

HIGH

Description

The function named ReadICONImage in coders\icon.c in ImageMagick 7.0.5-5 has a memory leak vulnerability which can cause memory exhaustion via a crafted ICON file.

References

http://www.debian.org/security/2017/dsa-3863

http://www.securityfocus.com/bid/98688

https://github.com/ImageMagick/ImageMagick/issues/466

Details

Source: MITRE

Published: 2017-05-04

Updated: 2019-10-03

Type: CWE-772

Risk Information

CVSS v2.0

Base Score: 7.1

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:C

Impact Score: 6.9

Exploitability Score: 8.6

Severity: HIGH

CVSS v3.0

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 2.8

Severity: MEDIUM