CVE-2017-7586

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

In libsndfile before 1.0.28, an error in the "header_read()" function (common.c) when handling ID3 tags can be exploited to cause a stack-based buffer overflow via a specially crafted FLAC file.

References

http://www.mega-nerd.com/libsndfile/#History

http://www.mega-nerd.com/libsndfile/NEWS

http://www.securityfocus.com/bid/97522

https://github.com/erikd/libsndfile/commit/708e996c87c5fae77b104ccfeb8f6db784c32074

https://github.com/erikd/libsndfile/commit/f457b7b5ecfe91697ed01cfc825772c4d8de1236

https://security.gentoo.org/glsa/201707-04

Details

Source: MITRE

Published: 2017-04-07

Updated: 2017-07-11

Type: CWE-119

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 5.5

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 1.8

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:libsndfile_project:libsndfile:*:*:*:*:*:*:*:* versions up to 1.0.27 (inclusive)

Tenable Plugins

View all (12 total)

IDNameProductFamilySeverity
132151EulerOS 2.0 SP3 : libsndfile (EulerOS-SA-2019-2616)NessusHuawei Local Security Checks
critical
131666EulerOS 2.0 SP2 : libsndfile (EulerOS-SA-2019-2513)NessusHuawei Local Security Checks
critical
130670EulerOS 2.0 SP5 : libsndfile (EulerOS-SA-2019-2208)NessusHuawei Local Security Checks
high
101691Fedora 26 : libsndfile (2017-a2a4f8d8a1)NessusFedora Local Security Checks
medium
101335GLSA-201707-04 : libsndfile: Multiple vulnerabilitiesNessusGentoo Local Security Checks
medium
100590Ubuntu 14.04 LTS / 16.04 LTS / 16.10 / 17.04 : libsndfile vulnerabilities (USN-3306-1)NessusUbuntu Local Security Checks
high
99739Debian DLA-928-1 : libsndfile security updateNessusDebian Local Security Checks
medium
99703openSUSE Security Update : libsndfile (openSUSE-2017-514)NessusSuSE Local Security Checks
medium
99554FreeBSD : libsndfile -- multiple vulnerabilities (5a97805e-93ef-4dcb-8d5e-dbcac263bfc2)NessusFreeBSD Local Security Checks
medium
99462SUSE SLED12 / SLES12 Security Update : libsndfile (SUSE-SU-2017:1040-1)NessusSuSE Local Security Checks
medium
99425Fedora 24 : libsndfile (2017-f676ecb20d)NessusFedora Local Security Checks
medium
99410Fedora 25 : libsndfile (2017-72a971ccf0)NessusFedora Local Security Checks
medium