CVE-2017-7559

MEDIUM

Description

In Undertow 2.x before 2.0.0.Alpha2, 1.4.x before 1.4.17.Final, and 1.3.x before 1.3.31.Final, it was found that the fix for CVE-2017-2666 was incomplete and invalid characters are still allowed in the query string and path parameters. This could be exploited, in conjunction with a proxy that also permitted the invalid characters but with a different interpretation, to inject data into the HTTP response. By manipulating the HTTP response the attacker could poison a web-cache, perform an XSS attack, or obtain sensitive information from requests other than their own.

References

https://access.redhat.com/errata/RHSA-2017:3454

https://access.redhat.com/errata/RHSA-2017:3455

https://access.redhat.com/errata/RHSA-2017:3456

https://access.redhat.com/errata/RHSA-2017:3458

https://access.redhat.com/errata/RHSA-2018:0002

https://access.redhat.com/errata/RHSA-2018:0003

https://access.redhat.com/errata/RHSA-2018:0004

https://access.redhat.com/errata/RHSA-2018:0005

https://access.redhat.com/errata/RHSA-2018:1322

https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-7559

https://issues.jboss.org/browse/UNDERTOW-1251

Details

Source: MITRE

Published: 2018-01-10

Updated: 2019-10-09

Type: CWE-444

Risk Information

CVSS v2.0

Base Score: 5.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:N

Impact Score: 4.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Impact Score: 2.7

Exploitability Score: 2.8

Severity: MEDIUM