CVE-2017-6439

LOW

Description

Heap-based buffer overflow in the parse_string_node function in bplist.c in libimobiledevice libplist 1.12 allows local users to cause a denial of service (out-of-bounds write) via a crafted plist file.

References

http://www.securityfocus.com/bid/97278

https://github.com/libimobiledevice/libplist/commit/32ee5213fe64f1e10ec76c1ee861ee6f233120dd

https://github.com/libimobiledevice/libplist/issues/95

Details

Source: MITRE

Published: 2017-03-15

Updated: 2017-04-04

Type: CWE-787

Risk Information

CVSS v2.0

Base Score: 1.9

Vector: (AV:L/AC:M/Au:N/C:N/I:N/A:P)

Impact Score: 2.9

Exploitability Score: 3.4

Severity: LOW

CVSS v3.0

Base Score: 5

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 1.3

Severity: MEDIUM