CVE-2017-6335

MEDIUM

Description

The QuantumTransferMode function in coders/tiff.c in GraphicsMagick 1.3.25 and earlier allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a small samples per pixel value in a CMYKA TIFF file.

References

http://www.openwall.com/lists/oss-security/2017/02/28/2

http://www.securityfocus.com/bid/96544

https://bugzilla.redhat.com/show_bug.cgi?id=1427975

https://lists.debian.org/debian-lts-announce/2018/08/msg00002.html

https://sourceforge.net/p/graphicsmagick/code/ci/6156b4c2992d855ece6079653b3b93c3229fc4b8/

Details

Source: MITRE

Published: 2017-03-14

Updated: 2018-08-04

Type: CWE-125

Risk Information

CVSS v2.0

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 5.5

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 1.8

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:graphicsmagick:graphicsmagick:*:*:*:*:*:*:*:* versions up to 1.3.25 (inclusive)

Tenable Plugins

View all (8 total)

IDNameProductFamilySeverity
131695Ubuntu 16.04 LTS : graphicsmagick vulnerabilities (USN-4206-1)NessusUbuntu Local Security Checks
high
111520Debian DLA-1456-1 : graphicsmagick security updateNessusDebian Local Security Checks
high
110628FreeBSD : GraphicsMagick -- multiple vulnerabilities (25f73c47-68a8-4a30-9cbc-1ca5eea4d6ba)NessusFreeBSD Local Security Checks
high
99533Amazon Linux AMI : GraphicsMagick (ALAS-2017-820)NessusAmazon Linux Local Security Checks
high
99152openSUSE Security Update : GraphicsMagick (openSUSE-2017-411)NessusSuSE Local Security Checks
medium
99112openSUSE Security Update : GraphicsMagick (openSUSE-2017-413)NessusSuSE Local Security Checks
medium
97684Fedora 24 : GraphicsMagick (2017-d2bab54ac9)NessusFedora Local Security Checks
high
97649Fedora 25 : GraphicsMagick (2017-c71a0f40f0)NessusFedora Local Security Checks
high