CVE-2017-5661

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

In Apache FOP before 2.2, files lying on the filesystem of the server which uses FOP can be revealed to arbitrary users who send maliciously formed SVG files. The file types that can be shown depend on the user context in which the exploitable application is running. If the user is root a full compromise of the server - including confidential or sensitive files - would be possible. XXE can also be used to attack the availability of the server via denial of service as the references within a xml document can trivially trigger an amplification attack.

References

https://xmlgraphics.apache.org/security.html

http://www.securityfocus.com/bid/97947

http://www.debian.org/security/2017/dsa-3864

Details

Source: MITRE

Published: 2017-04-18

Updated: 2021-07-22

Type: CWE-611

Risk Information

CVSS v2

Base Score: 7.9

Vector: AV:N/AC:M/Au:S/C:C/I:N/A:C

Impact Score: 9.2

Exploitability Score: 6.8

Severity: HIGH

CVSS v3

Base Score: 7.3

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:H

Impact Score: 5.2

Exploitability Score: 2.1

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:apache:formatting_objects_processor:*:*:*:*:*:*:*:* versions up to 2.1 (inclusive)

Tenable Plugins

View all (5 total)

IDNameProductFamilySeverity
152986Tenable SecurityCenter < 5.19.0 Multiple Vulnerabilities (TNS-2021-14)NessusMisc.
high
151985Tenable.sc < 5.19.0 Multiple Vulnerabilities (TNS-2021-14) (deprecated)NessusMisc.
high
100483Debian DSA-3864-1 : fop - security updateNessusDebian Local Security Checks
high
100100Ubuntu 14.04 LTS : fop vulnerability (USN-3281-1)NessusUbuntu Local Security Checks
high
99738Debian DLA-927-1 : fop security updateNessusDebian Local Security Checks
high