CVE-2017-5601

MEDIUM

Description

An error in the lha_read_file_header_1() function (archive_read_support_format_lha.c) in libarchive 3.2.2 allows remote attackers to trigger an out-of-bounds read memory access and subsequently cause a crash via a specially crafted archive.

References

http://www.securityfocus.com/bid/95837

http://www.securitytracker.com/id/1037974

https://github.com/libarchive/libarchive/commit/98dcbbf0bf4854bf987557e55e55fff7abbf3ea9

https://lists.debian.org/debian-lts-announce/2018/11/msg00037.html

https://secunia.com/secunia_research/2017-3/

Details

Source: MITRE

Published: 2017-01-27

Updated: 2018-11-30

Type: CWE-125

Risk Information

CVSS v2.0

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH