CVE-2017-5492

MEDIUM

Description

Cross-site request forgery (CSRF) vulnerability in the widget-editing accessibility-mode feature in WordPress before 4.7.1 allows remote attackers to hijack the authentication of unspecified victims for requests that perform a widgets-access action, related to wp-admin/includes/class-wp-screen.php and wp-admin/widgets.php.

References

http://www.debian.org/security/2017/dsa-3779

http://www.openwall.com/lists/oss-security/2017/01/14/6

http://www.securityfocus.com/bid/95407

http://www.securitytracker.com/id/1037591

https://codex.wordpress.org/Version_4.7.1

https://github.com/WordPress/WordPress/commit/03e5c0314aeffe6b27f4b98fef842bf0fb00c733

https://wordpress.org/news/2017/01/wordpress-4-7-1-security-and-maintenance-release/

https://wpvulndb.com/vulnerabilities/8720

Details

Source: MITRE

Published: 2017-01-15

Updated: 2017-11-04

Type: CWE-352

Risk Information

CVSS v2.0

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH