CVE-2017-5386

HIGH

Description

WebExtension scripts can use the "data:" protocol to affect pages loaded by other web extensions using this protocol, leading to potential data disclosure or privilege escalation in affected extensions. This vulnerability affects Firefox ESR < 45.7 and Firefox < 51.

References

http://rhn.redhat.com/errata/RHSA-2017-0190.html

http://www.securityfocus.com/bid/95769

http://www.securitytracker.com/id/1037693

https://bugzilla.mozilla.org/show_bug.cgi?id=1319070

https://security.gentoo.org/glsa/201702-22

https://www.debian.org/security/2017/dsa-3771

https://www.mozilla.org/security/advisories/mfsa2017-01/

https://www.mozilla.org/security/advisories/mfsa2017-02/

Details

Source: MITRE

Published: 2018-06-11

Updated: 2019-10-03

Risk Information

CVSS v2.0

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3.0

Base Score: 7.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Impact Score: 3.4

Exploitability Score: 3.9

Severity: HIGH