CVE-2017-5340

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Zend/zend_hash.c in PHP before 7.0.15 and 7.1.x before 7.1.1 mishandles certain cases that require large array allocations, which allows remote attackers to execute arbitrary code or cause a denial of service (integer overflow, uninitialized memory access, and use of arbitrary destructor function pointers) via crafted serialized data.

References

http://www.securityfocus.com/bid/95371

http://www.securitytracker.com/id/1037659

https://access.redhat.com/errata/RHSA-2018:1296

https://bugs.php.net/bug.php?id=73832

https://github.com/php/php-src/commit/4cc0286f2f3780abc6084bcdae5dce595daa3c12

https://security.netapp.com/advisory/ntap-20180112-0001/

Details

Source: MITRE

Published: 2017-01-11

Updated: 2018-05-04

Type: CWE-190

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (10 total)

IDNameProductFamilySeverity
98856PHP 7.1.x < 7.1.1 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98839PHP 7.0.x < 7.0.15 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
119993SUSE SLES12 Security Update : php7 (SUSE-SU-2017:0534-1)NessusSuSE Local Security Checks
critical
99039Amazon Linux AMI : php70 (ALAS-2017-812)NessusAmazon Linux Local Security Checks
critical
97563openSUSE Security Update : php7 (openSUSE-2017-304)NessusSuSE Local Security Checks
critical
97521Ubuntu 16.04 LTS / 16.10 : php7.0 regression (USN-3211-2)NessusUbuntu Local Security Checks
critical
97384Ubuntu 16.04 LTS / 16.10 : php7.0 vulnerabilities (USN-3211-1)NessusUbuntu Local Security Checks
critical
9938PHP 7.0.x < 7.0.15 / 7.1.x < 7.1.1 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
critical
96801PHP 7.1.x < 7.1.1 Multiple VulnerabilitiesNessusCGI abuses
critical
96800PHP 7.0.x < 7.0.15 Multiple VulnerabilitiesNessusCGI abuses
critical