CVE-2017-3161

MEDIUM

Description

The HDFS web UI in Apache Hadoop before 2.7.0 is vulnerable to a cross-site scripting (XSS) attack through an unescaped query parameter.

References

http://www.securityfocus.com/bid/98025

https://lists.apache.org/thread.html/[email protected]%3Cuser.hadoop.apache.org%3E

https://s.apache.org/4MQm

Details

Source: MITRE

Published: 2017-04-26

Updated: 2020-06-04

Type: CWE-79

Risk Information

CVSS v2.0

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Impact Score: 2.7

Exploitability Score: 2.8

Severity: MEDIUM