CVE-2017-2994

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Adobe Flash Player versions 24.0.0.194 and earlier have an exploitable use after free vulnerability in Primetime SDK event dispatch. Successful exploitation could lead to arbitrary code execution.

References

http://rhn.redhat.com/errata/RHSA-2017-0526.html

http://www.securityfocus.com/bid/96199

http://www.securitytracker.com/id/1037815

https://helpx.adobe.com/security/products/flash-player/apsb17-04.html

https://security.gentoo.org/glsa/201702-20

Details

Source: MITRE

Published: 2017-02-15

Updated: 2018-01-05

Type: CWE-416

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH

Tenable Plugins

View all (7 total)

IDNameProductFamilySeverity
97766RHEL 6 : flash-plugin (RHSA-2017:0526)NessusRed Hat Local Security Checks
critical
97325MS17-005: Security Update for Adobe Flash Player (4010250)NessusWindows : Microsoft Bulletins
critical
97300SUSE SLED12 Security Update : flash-player (SUSE-SU-2017:0523-1)NessusSuSE Local Security Checks
critical
97263GLSA-201702-20 : Adobe Flash Player: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
9966Flash Player < 24.0.0.221 Multiple Vulnerabilities (APSB17-04)Nessus Network MonitorWeb Clients
critical
97143Adobe Flash Player for Mac <= 24.0.0.194 Multiple Vulnerabilities (APSB17-04)NessusMacOS X Local Security Checks
critical
97142Adobe Flash Player <= 24.0.0.194 Multiple Vulnerabilities (APSB17-04)NessusWindows
critical