CVE-2017-2816

MEDIUM

Description

An exploitable buffer overflow vulnerability exists in the tag parsing functionality of LibOFX 0.9.11. A specially crafted OFX file can cause a write out of bounds resulting in a buffer overflow on the stack. An attacker can construct a malicious OFX file to trigger this vulnerability.

References

http://www.securityfocus.com/bid/100828

https://lists.debian.org/debian-lts-announce/2017/11/msg00038.html

https://security.gentoo.org/glsa/201908-26

https://www.talosintelligence.com/vulnerability_reports/TALOS-2017-0317

Details

Source: MITRE

Published: 2017-09-13

Updated: 2018-02-04

Type: CWE-119

Risk Information

CVSS v2.0

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH