CVE-2017-2666

MEDIUM

Description

It was discovered in Undertow that the code that parsed the HTTP request line permitted invalid characters. This could be exploited, in conjunction with a proxy that also permitted the invalid characters but with a different interpretation, to inject data into the HTTP response. By manipulating the HTTP response the attacker could poison a web-cache, perform an XSS attack, or obtain sensitive information from requests other than their own.

References

http://rhn.redhat.com/errata/RHSA-2017-1409.html

http://www.securityfocus.com/bid/98966

https://access.redhat.com/errata/RHSA-2017:1410

https://access.redhat.com/errata/RHSA-2017:1411

https://access.redhat.com/errata/RHSA-2017:1412

https://access.redhat.com/errata/RHSA-2017:3454

https://access.redhat.com/errata/RHSA-2017:3455

https://access.redhat.com/errata/RHSA-2017:3456

https://access.redhat.com/errata/RHSA-2017:3458

https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2666

https://www.debian.org/security/2017/dsa-3906

Details

Source: MITRE

Published: 2018-07-27

Updated: 2019-10-09

Type: CWE-444

Risk Information

CVSS v2.0

Base Score: 6.4

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:N

Impact Score: 4.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3.0

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Impact Score: 2.5

Exploitability Score: 3.9

Severity: MEDIUM