CVE-2017-2630

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

A stack buffer overflow flaw was found in the Quick Emulator (QEMU) before 2.9 built with the Network Block Device (NBD) client support. The flaw could occur while processing server's response to a 'NBD_OPT_LIST' request. A malicious NBD server could use this issue to crash a remote NBD client resulting in DoS or potentially execute arbitrary code on client host with privileges of the QEMU process.

References

https://lists.gnu.org/archive/html/qemu-devel/2017-02/msg01246.html

https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2630

http://www.openwall.com/lists/oss-security/2017/02/15/2

https://security.gentoo.org/glsa/201704-01

https://access.redhat.com/errata/RHSA-2017:2392

http://www.securityfocus.com/bid/96265

https://bugzilla.redhat.com/show_bug.cgi?id=1422415

https://github.com/qemu/qemu/commit/2563c9c6b8670400c48e562034b321a7cf3d9a85

Details

Source: MITRE

Published: 2018-07-27

Updated: 2021-09-08

Type: CWE-121

Risk Information

CVSS v2

Base Score: 6.5

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8

Severity: MEDIUM

CVSS v3

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:qemu:qemu:*:*:*:*:*:*:*:*

Tenable Plugins

View all (2 total)

IDNameProductFamilySeverity
102158RHEL 7 : qemu-kvm-rhev (RHSA-2017:2392)NessusRed Hat Local Security Checks
high
99274GLSA-201704-01 : QEMU: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical