CVE-2017-16943

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The receive_msg function in receive.c in the SMTP daemon in Exim 4.88 and 4.89 allows remote attackers to execute arbitrary code or cause a denial of service (use-after-free) via vectors involving BDAT commands.

References

https://git.exim.org/exim.git/commitdiff/4e6ae6235c68de243b1c2419027472d7659aa2b4

https://bugs.exim.org/show_bug.cgi?id=2199

https://lists.exim.org/lurker/message/20171125.034842.d1d75cac.en.html

https://github.com/LetUsFsck/PoC-Exploit-Mirror/tree/master/CVE-2017-16944

https://git.exim.org/exim.git/commit/4090d62a4b25782129cc1643596dc2f6e8f63bde

http://openwall.com/lists/oss-security/2017/11/25/3

http://openwall.com/lists/oss-security/2017/11/25/2

http://openwall.com/lists/oss-security/2017/11/25/1

http://www.securitytracker.com/id/1039872

https://www.debian.org/security/2017/dsa-4053

http://www.openwall.com/lists/oss-security/2021/05/04/7

Details

Source: MITRE

Published: 2017-11-25

Updated: 2021-05-04

Type: CWE-416

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (9 total)

IDNameProductFamilySeverity
149614openSUSE Security Update : exim (openSUSE-2021-677) (Stack Clash)NessusSuSE Local Security Checks
critical
107178GLSA-201803-01 : Exim: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
105803Fedora 27 : exim (2017-0053bb9719)NessusFedora Local Security Checks
critical
105417Amazon Linux AMI : exim (ALAS-2017-932)NessusAmazon Linux Local Security Checks
critical
105232openSUSE Security Update : exim (openSUSE-2017-1342)NessusSuSE Local Security Checks
critical
105196Fedora 26 : exim (2017-0032baa7d7)NessusFedora Local Security Checks
critical
104940Debian DSA-4053-1 : exim4 - security updateNessusDebian Local Security Checks
critical
104815Exim < 4.89.1 Use-After-Free BDAT Remote Code ExecutionNessusSMTP problems
critical
104808Ubuntu 17.04 / 17.10 : exim4 vulnerability (USN-3493-1)NessusUbuntu Local Security Checks
critical