CVE-2017-14503

MEDIUM

Description

libarchive 3.3.2 suffers from an out-of-bounds read within lha_read_data_none() in archive_read_support_format_lha.c when extracting a specially crafted lha archive, related to lha_crc16.

References

https://bugs.debian.org/875960

https://github.com/libarchive/libarchive/issues/948

https://lists.debian.org/debian-lts-announce/2018/11/msg00037.html

https://usn.ubuntu.com/3736-1/

https://www.debian.org/security/2018/dsa-4360

Details

Source: MITRE

Published: 2017-09-17

Updated: 2018-12-28

Type: CWE-125

Risk Information

CVSS v2.0

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 2.8

Severity: MEDIUM