CVE-2017-14051

MEDIUM

Description

An integer overflow in the qla2x00_sysfs_write_optrom_ctl function in drivers/scsi/qla2xxx/qla_attr.c in the Linux kernel through 4.12.10 allows local users to cause a denial of service (memory corruption and system crash) by leveraging root access.

References

http://www.securityfocus.com/bid/100571

https://bugzilla.kernel.org/show_bug.cgi?id=194061

https://lists.debian.org/debian-lts-announce/2017/12/msg00004.html

https://patchwork.kernel.org/patch/9929625/

https://usn.ubuntu.com/3583-1/

https://usn.ubuntu.com/3583-2/

Details

Source: MITRE

Published: 2017-08-31

Updated: 2018-03-16

Type: CWE-190

Risk Information

CVSS v2.0

Base Score: 4.9

Vector: AV:L/AC:L/Au:N/C:N/I:N/A:C

Impact Score: 6.9

Exploitability Score: 3.9

Severity: MEDIUM

CVSS v3.0

Base Score: 4.4

Vector: CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 0.8

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* versions up to 4.12.10 (inclusive)

Tenable Plugins

View all (17 total)

IDNameProductFamilySeverity
131845EulerOS 2.0 SP2 : kernel (EulerOS-SA-2019-2353)NessusHuawei Local Security Checks
critical
124983EulerOS Virtualization for ARM 64 3.0.1.0 : kernel (EulerOS-SA-2019-1530)NessusHuawei Local Security Checks
high
120977Oracle Linux 6 / 7 : Unbreakable Enterprise kernel (ELSA-2019-4316)NessusOracle Linux Local Security Checks
high
107003Ubuntu 14.04 LTS : linux vulnerabilities (USN-3583-1) (Meltdown)NessusUbuntu Local Security Checks
critical
105172SUSE SLES11 Security Update : kernel (SUSE-SU-2017:3265-1) (KRACK)NessusSuSE Local Security Checks
critical
105116Debian DLA-1200-1 : linux security update (KRACK)NessusDebian Local Security Checks
high
104374SUSE SLES12 Security Update : kernel (SUSE-SU-2017:2920-1) (KRACK) (Stack Clash)NessusSuSE Local Security Checks
critical
104321Ubuntu 14.04 LTS : linux-lts-xenial vulnerabilities (USN-3469-2)NessusUbuntu Local Security Checks
high
104320Ubuntu 16.04 LTS : linux, linux-aws, linux-gke, linux-kvm, linux-raspi2, linux-snapdragon vulnerabilities (USN-3469-1)NessusUbuntu Local Security Checks
high
104271SUSE SLES12 Security Update : kernel (SUSE-SU-2017:2908-1) (KRACK) (Stack Clash)NessusSuSE Local Security Checks
critical
104253SUSE SLED12 / SLES12 Security Update : kernel (SUSE-SU-2017:2869-1) (KRACK)NessusSuSE Local Security Checks
high
104171SUSE SLED12 / SLES12 Security Update : kernel (SUSE-SU-2017:2847-1) (KRACK)NessusSuSE Local Security Checks
high
103354SUSE SLES11 Security Update : kernel (SUSE-SU-2017:2525-1) (Stack Clash)NessusSuSE Local Security Checks
critical
103287openSUSE Security Update : the Linux Kernel (openSUSE-2017-1062) (BlueBorne)NessusSuSE Local Security Checks
high
103155openSUSE Security Update : the Linux Kernel (openSUSE-2017-1017)NessusSuSE Local Security Checks
high
103151Fedora 25 : kernel (2017-a3a8638a60)NessusFedora Local Security Checks
medium
103117Fedora 26 : kernel (2017-6764d16965)NessusFedora Local Security Checks
medium