CVE-2017-13144

MEDIUM

Description

In ImageMagick before 6.9.7-10, there is a crash (rather than a "width or height exceeds limit" error report) if the image dimensions are too large, as demonstrated by use of the mpc coder.

References

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=869728

https://security.gentoo.org/glsa/201711-07

https://usn.ubuntu.com/3681-1/

https://www.debian.org/security/2017/dsa-4019

https://www.debian.org/security/2017/dsa-4040

https://www.imagemagick.org/discourse-server/viewtopic.php?f=3&t=31438

Details

Source: MITRE

Published: 2017-08-23

Updated: 2018-06-14

Type: CWE-20

Risk Information

CVSS v2.0

Base Score: 4.3

Vector: (AV:N/AC:M/Au:N/C:N/I:N/A:P)

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 2.8

Severity: MEDIUM