CVE-2017-12934

MEDIUM

Description

ext/standard/var_unserializer.re in PHP 7.0.x before 7.0.21 and 7.1.x before 7.1.7 is prone to a heap use after free while unserializing untrusted data, related to the zval_get_type function in Zend/zend_types.h. Exploitation of this issue can have an unspecified impact on the integrity of PHP.

References

http://php.net/ChangeLog-7.php

http://www.securityfocus.com/bid/100428

https://access.redhat.com/errata/RHSA-2018:1296

https://bugs.php.net/bug.php?id=74101

https://www.debian.org/security/2018/dsa-4080

Details

Source: MITRE

Published: 2017-08-18

Updated: 2018-05-04

Type: CWE-416

Risk Information

CVSS v2.0

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (7 total)

IDNameProductFamilySeverity
98864PHP 7.1.x < 7.1.7 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98844PHP 7.0.x < 7.0.21 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
120006SUSE SLES12 Security Update : php7 (SUSE-SU-2017:2468-1)NessusSuSE Local Security Checks
high
105663Debian DSA-4080-1 : php7.0 - security updateNessusDebian Local Security Checks
high
103286openSUSE Security Update : php7 (openSUSE-2017-1061)NessusSuSE Local Security Checks
high
101527PHP 7.1.x < 7.1.7 Multiple VulnerabilitiesNessusCGI abuses
high
101526PHP 7.0.x < 7.0.21 Multiple VulnerabilitiesNessusCGI abuses
high