CVE-2017-12933

HIGH

Description

The finish_nested_data function in ext/standard/var_unserializer.re in PHP before 5.6.31, 7.0.x before 7.0.21, and 7.1.x before 7.1.7 is prone to a buffer over-read while unserializing untrusted data. Exploitation of this issue can have an unspecified impact on the integrity of PHP.

References

http://php.net/ChangeLog-5.php

http://php.net/ChangeLog-7.php

http://www.securityfocus.com/bid/99490

https://access.redhat.com/errata/RHSA-2018:1296

https://bugs.php.net/bug.php?id=74111

https://usn.ubuntu.com/3566-1/

https://usn.ubuntu.com/3566-2/

https://www.debian.org/security/2018/dsa-4080

https://www.debian.org/security/2018/dsa-4081

Details

Source: MITRE

Published: 2017-08-18

Updated: 2019-10-03

Type: CWE-125

Risk Information

CVSS v2.0

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (21 total)

IDNameProductFamilySeverity
137966EulerOS Virtualization 3.0.6.0 : php (EulerOS-SA-2020-1747)NessusHuawei Local Security Checks
critical
132184EulerOS 2.0 SP3 : php (EulerOS-SA-2019-2649)NessusHuawei Local Security Checks
critical
131592EulerOS 2.0 SP2 : php (EulerOS-SA-2019-2438)NessusHuawei Local Security Checks
critical
130683EulerOS 2.0 SP5 : php (EulerOS-SA-2019-2221)NessusHuawei Local Security Checks
critical
125352Ubuntu 14.04 LTS : PHP vulnerabilities (USN-3566-2)NessusUbuntu Local Security Checks
high
98864PHP 7.1.x < 7.1.7 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98844PHP 7.0.x < 7.0.21 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98822PHP 5.6.x < 5.6.31 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
120007SUSE SLES12 Security Update : php5 (SUSE-SU-2017:2518-1)NessusSuSE Local Security Checks
high
120006SUSE SLES12 Security Update : php7 (SUSE-SU-2017:2468-1)NessusSuSE Local Security Checks
high
106792Ubuntu 14.04 LTS : php5 vulnerabilities (USN-3566-1)NessusUbuntu Local Security Checks
high
105664Debian DSA-4081-1 : php5 - security updateNessusDebian Local Security Checks
high
105663Debian DSA-4080-1 : php7.0 - security updateNessusDebian Local Security Checks
high
103395openSUSE Security Update : php5 (openSUSE-2017-1079)NessusSuSE Local Security Checks
high
103317SUSE SLES11 Security Update : php53 (SUSE-SU-2017:2522-1)NessusSuSE Local Security Checks
high
103286openSUSE Security Update : php7 (openSUSE-2017-1061)NessusSuSE Local Security Checks
high
103121Tenable SecurityCenter PHP < 5.6.31 Multiple Vulnerabilities (TNS-2017-12NessusMisc.
high
102843Debian DLA-1076-1 : php5 security updateNessusDebian Local Security Checks
high
101527PHP 7.1.x < 7.1.7 Multiple VulnerabilitiesNessusCGI abuses
high
101526PHP 7.0.x < 7.0.21 Multiple VulnerabilitiesNessusCGI abuses
high
101525PHP 5.6.x < 5.6.31 Multiple VulnerabilitiesNessusCGI abuses
high