CVE-2017-12435

HIGH

Description

In ImageMagick 7.0.6-1, a memory exhaustion vulnerability was found in the function ReadSUNImage in coders/sun.c, which allows attackers to cause a denial of service.

References

http://www.securityfocus.com/bid/100152

https://github.com/ImageMagick/ImageMagick/issues/543

https://lists.debian.org/debian-lts-announce/2019/05/msg00015.html

https://usn.ubuntu.com/3681-1/

Details

Source: MITRE

Published: 2017-08-04

Updated: 2019-10-03

Type: CWE-770

Risk Information

CVSS v2.0

Base Score: 7.8

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:C

Impact Score: 6.9

Exploitability Score: 10

Severity: HIGH

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH