CVE-2017-12194

HIGH

Description

A flaw was found in the way spice-client processed certain messages sent from the server. An attacker, having control of malicious spice-server, could use this flaw to crash the client or execute arbitrary code with permissions of the user running the client. spice-gtk versions through 0.34 are believed to be vulnerable.

References

http://www.securityfocus.com/bid/103413

https://bugzilla.redhat.com/show_bug.cgi?id=1501200

https://security.gentoo.org/glsa/201811-20

https://usn.ubuntu.com/3659-1/

Details

Source: MITRE

Published: 2018-03-14

Updated: 2018-11-27

Type: CWE-20

Risk Information

CVSS v2.0

Base Score: 10

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 10

Severity: HIGH

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL