CVE-2017-11638

MEDIUM

Description

GraphicsMagick 1.3.26 has a segmentation violation in the WriteMAPImage() function in coders/map.c when processing a non-colormapped image, a different vulnerability than CVE-2017-11642.

References

http://hg.code.sf.net/p/graphicsmagick/code/rev/29550606d8b9

https://lists.debian.org/debian-lts-announce/2018/08/msg00002.html

https://www.debian.org/security/2018/dsa-4321

Details

Source: MITRE

Published: 2017-07-26

Updated: 2018-10-18

Type: CWE-20

Risk Information

CVSS v2.0

Base Score: 6.8

Vector: (AV:N/AC:M/Au:N/C:P/I:P/A:P)

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH