CVE-2017-11628

MEDIUM

Description

In PHP before 5.6.31, 7.x before 7.0.21, and 7.1.x before 7.1.7, a stack-based buffer overflow in the zend_ini_do_op() function in Zend/zend_ini_parser.c could cause a denial of service or potentially allow executing code. NOTE: this is only relevant for PHP applications that accept untrusted input (instead of the system's php.ini file) for the parse_ini_string or parse_ini_file function, e.g., a web application for syntax validation of php.ini directives.

References

http://git.php.net/?p=php-src.git;a=commit;h=05255749139b3686c8a6a58ee01131ac0047465e

http://git.php.net/?p=php-src.git;a=commit;h=5f8380d33e648964d2d5140f329cf2d4c443033c

http://www.securityfocus.com/bid/99489

https://access.redhat.com/errata/RHSA-2018:1296

https://bugs.php.net/bug.php?id=74603

https://security.gentoo.org/glsa/201709-21

https://security.netapp.com/advisory/ntap-20180112-0001/

https://www.debian.org/security/2018/dsa-4080

https://www.debian.org/security/2018/dsa-4081

Details

Source: MITRE

Published: 2017-07-25

Updated: 2018-05-04

Type: CWE-119

Risk Information

CVSS v2.0

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 1.8

Severity: HIGH

Tenable Plugins

View all (22 total)

IDNameProductFamilySeverity
137966EulerOS Virtualization 3.0.6.0 : php (EulerOS-SA-2020-1747)NessusHuawei Local Security Checks
critical
132184EulerOS 2.0 SP3 : php (EulerOS-SA-2019-2649)NessusHuawei Local Security Checks
critical
131592EulerOS 2.0 SP2 : php (EulerOS-SA-2019-2438)NessusHuawei Local Security Checks
critical
129178EulerOS 2.0 SP5 : php (EulerOS-SA-2019-1984)NessusHuawei Local Security Checks
high
98864PHP 7.1.x < 7.1.7 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98844PHP 7.0.x < 7.0.21 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98822PHP 5.6.x < 5.6.31 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
120004SUSE SLES12 Security Update : php5 (SUSE-SU-2017:2317-1)NessusSuSE Local Security Checks
medium
120003SUSE SLES12 Security Update : php7 (SUSE-SU-2017:2303-1)NessusSuSE Local Security Checks
medium
110059F5 Networks BIG-IP : PHP vulnerability (K75543432)NessusF5 Networks Local Security Checks
medium
105664Debian DSA-4081-1 : php5 - security updateNessusDebian Local Security Checks
high
105663Debian DSA-4080-1 : php7.0 - security updateNessusDebian Local Security Checks
high
103449GLSA-201709-21 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
103317SUSE SLES11 Security Update : php53 (SUSE-SU-2017:2522-1)NessusSuSE Local Security Checks
high
103121Tenable SecurityCenter PHP < 5.6.31 Multiple Vulnerabilities (TNS-2017-12NessusMisc.
high
102966openSUSE Security Update : php5 (openSUSE-2017-1010)NessusSuSE Local Security Checks
medium
102947openSUSE Security Update : php7 (openSUSE-2017-994)NessusSuSE Local Security Checks
high
102786Debian DLA-1066-1 : php5 security updateNessusDebian Local Security Checks
medium
102416Ubuntu 14.04 LTS / 16.04 LTS / 17.04 : php5, php7.0 vulnerabilities (USN-3382-1)NessusUbuntu Local Security Checks
high
101527PHP 7.1.x < 7.1.7 Multiple VulnerabilitiesNessusCGI abuses
high
101526PHP 7.0.x < 7.0.21 Multiple VulnerabilitiesNessusCGI abuses
high
101525PHP 5.6.x < 5.6.31 Multiple VulnerabilitiesNessusCGI abuses
high