CVE-2017-11509

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

An authenticated remote attacker can execute arbitrary code in Firebird SQL Server versions 2.5.7 and 3.0.2 by executing a malformed SQL statement.

References

https://lists.debian.org/debian-lts-announce/2018/05/msg00005.html

https://lists.debian.org/debian-lts-announce/2020/02/msg00036.html

https://www.tenable.com/security/research/tra-2017-36

Details

Source: MITRE

Published: 2018-03-28

Updated: 2020-02-29

Type: CWE-89

Risk Information

CVSS v2

Base Score: 9

Vector: AV:N/AC:L/Au:S/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 8

Severity: HIGH

CVSS v3

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH

Tenable Plugins

View all (2 total)

IDNameProductFamilySeverity
134180Debian DLA-2129-1 : firebird2.5 security updateNessusDebian Local Security Checks
high
109734Debian DLA-1374-1 : firebird2.5 security updateNessusDebian Local Security Checks
high