CVE-2017-11449

HIGH
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

coders/mpc.c in ImageMagick before 7.0.6-1 does not enable seekable streams and thus cannot validate blob sizes, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via an image received from stdin.

References

https://github.com/ImageMagick/ImageMagick/issues/556

https://github.com/ImageMagick/ImageMagick/commit/b007dd3a048097d8f58949297f5b434612e1e1a3

https://github.com/ImageMagick/ImageMagick/commit/529ff26b68febb2ac03062c58452ea0b4c6edbc1

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=867896

http://www.securityfocus.com/bid/99958

Details

Source: MITRE

Published: 2017-07-19

Updated: 2021-04-20

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 8.8

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH

Tenable Plugins

View all (9 total)

IDNameProductFamilySeverity
106186SUSE SLES11 Security Update : ImageMagick (SUSE-SU-2018:0132-1)NessusSuSE Local Security Checks
high
106065openSUSE Security Update : ImageMagick (openSUSE-2018-36)NessusSuSE Local Security Checks
high
106064openSUSE Security Update : GraphicsMagick (openSUSE-2018-35)NessusSuSE Local Security Checks
high
105721SUSE SLED12 / SLES12 Security Update : ImageMagick (SUSE-SU-2018:0055-1)NessusSuSE Local Security Checks
high
103333Fedora 25 : 1:emacs / ImageMagick / WindowMaker / autotrace / converseen / etc (2017-3a568adb31)NessusFedora Local Security Checks
critical
103314Fedora 26 : 1:emacs / ImageMagick / WindowMaker / autotrace / converseen / etc (2017-8f27031c8f)NessusFedora Local Security Checks
critical
102889Debian DLA-1081-1 : imagemagick security updateNessusDebian Local Security Checks
critical
101950Ubuntu 14.04 LTS / 16.04 LTS / 17.04 : imagemagick vulnerabilities (USN-3363-1)NessusUbuntu Local Security Checks
high
101794Debian DSA-3914-1 : imagemagick - security updateNessusDebian Local Security Checks
high