CVE-2017-11362

CRITICAL
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

In PHP 7.x before 7.0.21 and 7.1.x before 7.1.7, ext/intl/msgformat/msgformat_parse.c does not restrict the locale length, which allows remote attackers to cause a denial of service (stack-based buffer overflow and application crash) or possibly have unspecified other impact within International Components for Unicode (ICU) for C/C++ via a long first argument to the msgfmt_parse_message function.

References

https://access.redhat.com/errata/RHSA-2018:1296

https://bugs.php.net/bug.php?id=73473

https://security.gentoo.org/glsa/201709-21

https://security.netapp.com/advisory/ntap-20180112-0001/

https://usn.ubuntu.com/3566-2/

Details

Source: MITRE

Published: 2017-07-17

Updated: 2019-05-22

Type: CWE-119

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (9 total)

IDNameProductFamilySeverity
142352EulerOS 2.0 SP2 : php (EulerOS-SA-2020-2384)NessusHuawei Local Security Checks
critical
140834EulerOS 2.0 SP3 : php (EulerOS-SA-2020-2067)NessusHuawei Local Security Checks
critical
125352Ubuntu 14.04 LTS : PHP vulnerabilities (USN-3566-2)NessusUbuntu Local Security Checks
critical
98864PHP 7.1.x < 7.1.7 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98844PHP 7.0.x < 7.0.21 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
103449GLSA-201709-21 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
102416Ubuntu 14.04 LTS / 16.04 LTS / 17.04 : php5, php7.0 vulnerabilities (USN-3382-1)NessusUbuntu Local Security Checks
critical
101527PHP 7.1.x < 7.1.7 Multiple VulnerabilitiesNessusCGI abuses
critical
101526PHP 7.0.x < 7.0.21 Multiple VulnerabilitiesNessusCGI abuses
critical