CVE-2017-11360

MEDIUM

Description

The ReadRLEImage function in coders\rle.c in ImageMagick 7.0.6-1 has a large loop vulnerability via a crafted rle file that triggers a huge number_pixels value.

References

https://github.com/ImageMagick/ImageMagick/issues/518

Details

Source: MITRE

Published: 2017-07-17

Updated: 2019-10-03

Type: CWE-834

Risk Information

CVSS v2.0

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 2.8

Severity: MEDIUM

Tenable Plugins

View all (5 total)

IDNameProductFamilySeverity
103333Fedora 25 : 1:emacs / ImageMagick / WindowMaker / autotrace / converseen / etc (2017-3a568adb31)NessusFedora Local Security Checks
high
103314Fedora 26 : 1:emacs / ImageMagick / WindowMaker / autotrace / converseen / etc (2017-8f27031c8f)NessusFedora Local Security Checks
high
102889Debian DLA-1081-1 : imagemagick security updateNessusDebian Local Security Checks
high
101950Ubuntu 14.04 LTS / 16.04 LTS / 17.04 : imagemagick vulnerabilities (USN-3363-1)NessusUbuntu Local Security Checks
high
101794Debian DSA-3914-1 : imagemagick - security updateNessusDebian Local Security Checks
high