CVE-2017-11145

MEDIUM

Description

In PHP before 5.6.31, 7.x before 7.0.21, and 7.1.x before 7.1.7, an error in the date extension's timelib_meridian parsing code could be used by attackers able to supply date strings to leak information from the interpreter, related to ext/date/lib/parse_date.c out-of-bounds reads affecting the php_parse_date function. NOTE: the correct fix is in the e8b7698f5ee757ce2c8bd10a192a491a498f891c commit, not the bd77ac90d3bdf31ce2a5251ad92e9e75 gist.

References

http://git.php.net/?p=php-src.git;a=commit;h=e8b7698f5ee757ce2c8bd10a192a491a498f891c

http://openwall.com/lists/oss-security/2017/07/10/6

http://php.net/ChangeLog-5.php

http://php.net/ChangeLog-7.php

http://www.securityfocus.com/bid/99550

https://access.redhat.com/errata/RHSA-2018:1296

https://bugs.php.net/bug.php?id=74819

https://gist.github.com/anonymous/bd77ac90d3bdf31ce2a5251ad92e9e75

https://security.netapp.com/advisory/ntap-20180112-0001/

https://www.debian.org/security/2018/dsa-4080

https://www.debian.org/security/2018/dsa-4081

https://www.tenable.com/security/tns-2017-12

Details

Source: MITRE

Published: 2017-07-10

Updated: 2018-05-04

Type: CWE-200

Risk Information

CVSS v2.0

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (19 total)

IDNameProductFamilySeverity
137966EulerOS Virtualization 3.0.6.0 : php (EulerOS-SA-2020-1747)NessusHuawei Local Security Checks
critical
136245EulerOS Virtualization for ARM 64 3.0.2.0 : php (EulerOS-SA-2020-1542)NessusHuawei Local Security Checks
medium
133925EulerOS 2.0 SP5 : php (EulerOS-SA-2020-1124)NessusHuawei Local Security Checks
high
98864PHP 7.1.x < 7.1.7 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98844PHP 7.0.x < 7.0.21 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98822PHP 5.6.x < 5.6.31 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
120004SUSE SLES12 Security Update : php5 (SUSE-SU-2017:2317-1)NessusSuSE Local Security Checks
medium
120003SUSE SLES12 Security Update : php7 (SUSE-SU-2017:2303-1)NessusSuSE Local Security Checks
medium
105664Debian DSA-4081-1 : php5 - security updateNessusDebian Local Security Checks
high
105663Debian DSA-4080-1 : php7.0 - security updateNessusDebian Local Security Checks
high
103317SUSE SLES11 Security Update : php53 (SUSE-SU-2017:2522-1)NessusSuSE Local Security Checks
high
103121Tenable SecurityCenter PHP < 5.6.31 Multiple Vulnerabilities (TNS-2017-12NessusMisc.
high
102966openSUSE Security Update : php5 (openSUSE-2017-1010)NessusSuSE Local Security Checks
medium
102947openSUSE Security Update : php7 (openSUSE-2017-994)NessusSuSE Local Security Checks
high
102416Ubuntu 14.04 LTS / 16.04 LTS / 17.04 : php5, php7.0 vulnerabilities (USN-3382-1)NessusUbuntu Local Security Checks
high
101908Debian DLA-1034-1 : php5 security updateNessusDebian Local Security Checks
medium
101527PHP 7.1.x < 7.1.7 Multiple VulnerabilitiesNessusCGI abuses
high
101526PHP 7.0.x < 7.0.21 Multiple VulnerabilitiesNessusCGI abuses
high
101525PHP 5.6.x < 5.6.31 Multiple VulnerabilitiesNessusCGI abuses
high