CVE-2017-11143

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

In PHP before 5.6.31, an invalid free in the WDDX deserialization of boolean parameters could be used by attackers able to inject XML for deserialization to crash the PHP interpreter, related to an invalid free for an empty boolean element in ext/wddx/wddx.c.

References

http://openwall.com/lists/oss-security/2017/07/10/6

http://php.net/ChangeLog-5.php

http://www.securityfocus.com/bid/99553

https://access.redhat.com/errata/RHSA-2018:1296

https://bugs.php.net/bug.php?id=74145

https://git.php.net/?p=php-src.git;a=commit;h=2aae60461c2ff7b7fbcdd194c789ac841d0747d7

https://security.netapp.com/advisory/ntap-20180112-0001/

https://www.debian.org/security/2018/dsa-4081

https://www.tenable.com/security/tns-2017-12

Details

Source: MITRE

Published: 2017-07-10

Updated: 2018-05-04

Type: CWE-416

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:php:php:*:*:*:*:*:*:*:* versions up to 5.6.30 (inclusive)

Tenable Plugins

View all (14 total)

IDNameProductFamilySeverity
137966EulerOS Virtualization 3.0.6.0 : php (EulerOS-SA-2020-1747)NessusHuawei Local Security Checks
critical
132184EulerOS 2.0 SP3 : php (EulerOS-SA-2019-2649)NessusHuawei Local Security Checks
critical
131592EulerOS 2.0 SP2 : php (EulerOS-SA-2019-2438)NessusHuawei Local Security Checks
critical
130683EulerOS 2.0 SP5 : php (EulerOS-SA-2019-2221)NessusHuawei Local Security Checks
critical
122542PHP 7.1.x < 7.1.8 Denial of Service VulnerabilityNessusCGI abuses
high
122538PHP 7.0.x < 7.0.22 Denial of Service VulnerabilityNessusCGI abuses
high
98822PHP 5.6.x < 5.6.31 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
120004SUSE SLES12 Security Update : php5 (SUSE-SU-2017:2317-1)NessusSuSE Local Security Checks
high
105664Debian DSA-4081-1 : php5 - security updateNessusDebian Local Security Checks
critical
103121Tenable SecurityCenter PHP < 5.6.31 Multiple Vulnerabilities (TNS-2017-12NessusMisc.
critical
102966openSUSE Security Update : php5 (openSUSE-2017-1010)NessusSuSE Local Security Checks
critical
102416Ubuntu 14.04 LTS / 16.04 LTS / 17.04 : php5, php7.0 vulnerabilities (USN-3382-1)NessusUbuntu Local Security Checks
critical
101908Debian DLA-1034-1 : php5 security updateNessusDebian Local Security Checks
critical
101525PHP 5.6.x < 5.6.31 Multiple VulnerabilitiesNessusCGI abuses
critical