CVE-2017-11141

HIGH

Description

The ReadMATImage function in coders\mat.c in ImageMagick 7.0.5-6 has a memory leak vulnerability that can cause memory exhaustion via a crafted MAT file, related to incorrect ordering of a SetImageExtent call.

References

http://www.securityfocus.com/bid/99506

https://github.com/ImageMagick/ImageMagick/issues/469

Details

Source: MITRE

Published: 2017-07-10

Updated: 2019-10-03

Type: CWE-772

Risk Information

CVSS v2.0

Base Score: 7.1

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:C

Impact Score: 6.9

Exploitability Score: 8.6

Severity: HIGH

CVSS v3.0

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 2.8

Severity: MEDIUM

Tenable Plugins

View all (8 total)

IDNameProductFamilySeverity
106221openSUSE Security Update : ImageMagick (openSUSE-2018-61)NessusSuSE Local Security Checks
high
106186SUSE SLES11 Security Update : ImageMagick (SUSE-SU-2018:0132-1)NessusSuSE Local Security Checks
high
106184SUSE SLED12 / SLES12 Security Update : ImageMagick (SUSE-SU-2018:0130-1)NessusSuSE Local Security Checks
high
103333Fedora 25 : 1:emacs / ImageMagick / WindowMaker / autotrace / converseen / etc (2017-3a568adb31)NessusFedora Local Security Checks
high
103314Fedora 26 : 1:emacs / ImageMagick / WindowMaker / autotrace / converseen / etc (2017-8f27031c8f)NessusFedora Local Security Checks
high
102889Debian DLA-1081-1 : imagemagick security updateNessusDebian Local Security Checks
high
101950Ubuntu 14.04 LTS / 16.04 LTS / 17.04 : imagemagick vulnerabilities (USN-3363-1)NessusUbuntu Local Security Checks
high
101794Debian DSA-3914-1 : imagemagick - security updateNessusDebian Local Security Checks
high