CVE-2017-1000422

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Gnome gdk-pixbuf 2.36.8 and older is vulnerable to several integer overflow in the gif_get_lzw function resulting in memory corruption and potential code execution

References

https://bugzilla.gnome.org/show_bug.cgi?id=785973

https://lists.debian.org/debian-lts-announce/2018/01/msg00007.html

https://security.gentoo.org/glsa/201804-14

https://usn.ubuntu.com/3532-1/

https://www.debian.org/security/2018/dsa-4088

Details

Source: MITRE

Published: 2018-01-02

Updated: 2019-05-02

Type: CWE-190

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH

Tenable Plugins

View all (8 total)

IDNameProductFamilySeverity
124941EulerOS Virtualization 3.0.1.0 : gdk-pixbuf2 (EulerOS-SA-2019-1438)NessusHuawei Local Security Checks
high
111196openSUSE Security Update : gdk-pixbuf (openSUSE-2018-741)NessusSuSE Local Security Checks
high
111102SUSE SLED12 / SLES12 Security Update : gdk-pixbuf (SUSE-SU-2018:1950-1)NessusSuSE Local Security Checks
high
109098GLSA-201804-14 : GDK-PixBuf: Remote code executionNessusGentoo Local Security Checks
high
106774EulerOS 2.0 SP2 : gdk-pixbuf2 (EulerOS-SA-2018-1046)NessusHuawei Local Security Checks
high
106773EulerOS 2.0 SP1 : gdk-pixbuf2 (EulerOS-SA-2018-1045)NessusHuawei Local Security Checks
high
106074Ubuntu 14.04 LTS / 16.04 LTS / 17.10 : gdk-pixbuf vulnerabilities (USN-3532-1)NessusUbuntu Local Security Checks
high
106056Debian DSA-4088-1 : gdk-pixbuf - security updateNessusDebian Local Security Checks
high