CVE-2017-1000256

MEDIUM

Description

libvirt version 2.3.0 and later is vulnerable to a bad default configuration of "verify-peer=no" passed to QEMU by libvirt resulting in a failure to validate SSL/TLS certificates by default.

References

http://www.debian.org/security/2017/dsa-4003

https://access.redhat.com/security/cve/CVE-2017-1000256

https://www.mail-archive.com/[email protected]/msg1556251.html

https://www.redhat.com/archives/libvirt-announce/2017-October/msg00001.html

Details

Source: MITRE

Published: 2017-10-31

Updated: 2017-11-30

Type: CWE-295

Risk Information

CVSS v2.0

Base Score: 6.8

Vector: (AV:N/AC:M/Au:N/C:P/I:P/A:P)

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.2

Severity: HIGH