CVE-2016-9936

HIGH

Description

The unserialize implementation in ext/standard/var.c in PHP 7.x before 7.0.14 allows remote attackers to cause a denial of service (use-after-free) or possibly have unspecified other impact via crafted serialized data. NOTE: this vulnerability exists because of an incomplete fix for CVE-2015-6834.

References

http://lists.opensuse.org/opensuse-updates/2017-01/msg00034.html

http://www.openwall.com/lists/oss-security/2016/12/12/2

http://www.php.net/ChangeLog-7.php

http://www.securityfocus.com/bid/94849

https://access.redhat.com/errata/RHSA-2018:1296

https://bugs.php.net/bug.php?id=72978

https://github.com/php/php-src/commit/b2af4e8868726a040234de113436c6e4f6372d17

Details

Source: MITRE

Published: 2017-01-04

Updated: 2018-05-04

Type: CWE-416

Risk Information

CVSS v2.0

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (10 total)

IDNameProductFamilySeverity
122540PHP 7.1.x < 7.1.0 Multiple Vulnerabilities.NessusCGI abuses
high
98838PHP 7.0.x < 7.0.14 php_wddx_push_element() Function Empty Boolean Element Decoding RCEWeb Application ScanningComponent Vulnerability
high
119989SUSE SLES12 Security Update : php7 (SUSE-SU-2017:0017-1)NessusSuSE Local Security Checks
high
97521Ubuntu 16.04 LTS / 16.10 : php7.0 regression (USN-3211-2)NessusUbuntu Local Security Checks
high
97384Ubuntu 16.04 LTS / 16.10 : php7.0 vulnerabilities (USN-3211-1)NessusUbuntu Local Security Checks
high
96806Amazon Linux AMI : php70 (ALAS-2017-788)NessusAmazon Linux Local Security Checks
high
96380openSUSE Security Update : php7 (openSUSE-2017-61)NessusSuSE Local Security Checks
high
96221FreeBSD : PHP -- multiple vulnerabilities (6972668d-cdb7-11e6-a9a5-b499baebfeaf)NessusFreeBSD Local Security Checks
high
9842PHP 7.0.x < 7.0.14 RCENessus Network MonitorWeb Servers
high
95875PHP 7.0.x < 7.0.14 Multiple VulnerabilitiesNessusCGI abuses
high