CVE-2016-9934

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

ext/wddx/wddx.c in PHP before 5.6.28 and 7.x before 7.0.13 allows remote attackers to cause a denial of service (NULL pointer dereference) via crafted serialized data in a wddxPacket XML document, as demonstrated by a PDORow string.

References

http://lists.opensuse.org/opensuse-updates/2016-12/msg00142.html

http://lists.opensuse.org/opensuse-updates/2017-01/msg00034.html

http://lists.opensuse.org/opensuse-updates/2017-01/msg00054.html

http://www.openwall.com/lists/oss-security/2016/12/12/2

http://www.php.net/ChangeLog-5.php

http://www.php.net/ChangeLog-7.php

http://www.securityfocus.com/bid/94845

https://access.redhat.com/errata/RHSA-2018:1296

https://bugs.php.net/bug.php?id=73331

https://github.com/php/php-src/commit/6045de69c7dedcba3eadf7c4bba424b19c81d00d

Details

Source: MITRE

Published: 2017-01-04

Updated: 2018-05-04

Type: CWE-476

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (23 total)

IDNameProductFamilySeverity
137966EulerOS Virtualization 3.0.6.0 : php (EulerOS-SA-2020-1747)NessusHuawei Local Security Checks
critical
132184EulerOS 2.0 SP3 : php (EulerOS-SA-2019-2649)NessusHuawei Local Security Checks
critical
131592EulerOS 2.0 SP2 : php (EulerOS-SA-2019-2438)NessusHuawei Local Security Checks
critical
130683EulerOS 2.0 SP5 : php (EulerOS-SA-2019-2221)NessusHuawei Local Security Checks
critical
122540PHP 7.1.x < 7.1.0 Multiple Vulnerabilities.NessusCGI abuses
critical
98837PHP 7.0.x < 7.0.13 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98818PHP 5.6.x < 5.6.28 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
119990SUSE SLES12 Security Update : php5 (SUSE-SU-2017:0038-1)NessusSuSE Local Security Checks
critical
119989SUSE SLES12 Security Update : php7 (SUSE-SU-2017:0017-1)NessusSuSE Local Security Checks
critical
97566openSUSE Security Update : php5 (openSUSE-2017-308)NessusSuSE Local Security Checks
critical
97190Ubuntu 12.04 LTS / 14.04 LTS : php5 vulnerabilities (USN-3196-1)NessusUbuntu Local Security Checks
critical
97052Debian DLA-818-1 : php5 security updateNessusDebian Local Security Checks
critical
96806Amazon Linux AMI : php70 (ALAS-2017-788)NessusAmazon Linux Local Security Checks
critical
96805Amazon Linux AMI : php56 (ALAS-2017-787)NessusAmazon Linux Local Security Checks
critical
96731macOS 10.12.x < 10.12.3 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
high
96431SUSE SLES11 Security Update : php53 (SUSE-SU-2017:0109-1)NessusSuSE Local Security Checks
critical
96381openSUSE Security Update : php5 (openSUSE-2017-62)NessusSuSE Local Security Checks
critical
96380openSUSE Security Update : php7 (openSUSE-2017-61)NessusSuSE Local Security Checks
critical
96130openSUSE Security Update : php5 (openSUSE-2016-1505)NessusSuSE Local Security Checks
critical
95776Debian DSA-3732-1 : php5 - security updateNessusDebian Local Security Checks
critical
95725Slackware 14.0 / 14.1 / 14.2 / current : php (SSA:2016-347-03)NessusSlackware Local Security Checks
critical
94956PHP 7.0.x < 7.0.13 Multiple VulnerabilitiesNessusCGI abuses
high
94955PHP 5.6.x < 5.6.28 Multiple VulnerabilitiesNessusCGI abuses
high