CVE-2016-9933

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Stack consumption vulnerability in the gdImageFillToBorder function in gd.c in the GD Graphics Library (aka libgd) before 2.2.2, as used in PHP before 5.6.28 and 7.x before 7.0.13, allows remote attackers to cause a denial of service (segmentation violation) via a crafted imagefilltoborder call that triggers use of a negative color value.

References

http://lists.opensuse.org/opensuse-updates/2016-12/msg00133.html

http://lists.opensuse.org/opensuse-updates/2016-12/msg00142.html

http://lists.opensuse.org/opensuse-updates/2017-01/msg00002.html

http://lists.opensuse.org/opensuse-updates/2017-01/msg00034.html

http://lists.opensuse.org/opensuse-updates/2017-01/msg00054.html

http://www.debian.org/security/2017/dsa-3751

http://www.openwall.com/lists/oss-security/2016/12/12/2

http://www.php.net/ChangeLog-5.php

http://www.php.net/ChangeLog-7.php

http://www.securityfocus.com/bid/94865

https://access.redhat.com/errata/RHSA-2018:1296

https://bugs.php.net/bug.php?id=72696

https://github.com/libgd/libgd/commit/77f619d48259383628c3ec4654b1ad578e9eb40e

https://github.com/libgd/libgd/issues/215

https://github.com/php/php-src/commit/863d37ea66d5c960db08d6f4a2cbd2518f0f80d1

Details

Source: MITRE

Published: 2017-01-04

Updated: 2018-05-04

Type: CWE-119

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (30 total)

IDNameProductFamilySeverity
151294EulerOS Virtualization for ARM 64 3.0.2.0 : gd (EulerOS-SA-2021-2071)NessusHuawei Local Security Checks
critical
147535EulerOS Virtualization 3.0.2.6 : gd (EulerOS-SA-2021-1431)NessusHuawei Local Security Checks
critical
147432EulerOS Virtualization 3.0.6.6 : gd (EulerOS-SA-2021-1473)NessusHuawei Local Security Checks
critical
146178EulerOS 2.0 SP5 : gd (EulerOS-SA-2021-1189)NessusHuawei Local Security Checks
critical
132300EulerOS 2.0 SP3 : gd (EulerOS-SA-2019-2583)NessusHuawei Local Security Checks
critical
131674EulerOS 2.0 SP2 : gd (EulerOS-SA-2019-2521)NessusHuawei Local Security Checks
critical
122540PHP 7.1.x < 7.1.0 Multiple Vulnerabilities.NessusCGI abuses
critical
98837PHP 7.0.x < 7.0.13 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98818PHP 5.6.x < 5.6.28 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
119990SUSE SLES12 Security Update : php5 (SUSE-SU-2017:0038-1)NessusSuSE Local Security Checks
critical
119989SUSE SLES12 Security Update : php7 (SUSE-SU-2017:0017-1)NessusSuSE Local Security Checks
critical
97566openSUSE Security Update : php5 (openSUSE-2017-308)NessusSuSE Local Security Checks
critical
97468Ubuntu 12.04 LTS / 14.04 LTS / 16.04 LTS / 16.10 : libgd2 vulnerabilities (USN-3213-1)NessusUbuntu Local Security Checks
critical
96806Amazon Linux AMI : php70 (ALAS-2017-788)NessusAmazon Linux Local Security Checks
critical
96805Amazon Linux AMI : php56 (ALAS-2017-787)NessusAmazon Linux Local Security Checks
critical
96731macOS 10.12.x < 10.12.3 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
high
96431SUSE SLES11 Security Update : php53 (SUSE-SU-2017:0109-1)NessusSuSE Local Security Checks
critical
96381openSUSE Security Update : php5 (openSUSE-2017-62)NessusSuSE Local Security Checks
critical
96380openSUSE Security Update : php7 (openSUSE-2017-61)NessusSuSE Local Security Checks
critical
96251openSUSE Security Update : gd (openSUSE-2017-3)NessusSuSE Local Security Checks
high
96195Debian DSA-3751-1 : libgd2 - security updateNessusDebian Local Security Checks
high
96136SUSE SLES11 Security Update : gd (SUSE-SU-2016:3251-1)NessusSuSE Local Security Checks
high
96131openSUSE Security Update : gd (openSUSE-2016-1510)NessusSuSE Local Security Checks
high
96130openSUSE Security Update : php5 (openSUSE-2016-1505)NessusSuSE Local Security Checks
critical
96085Debian DLA-758-1 : libgd2 security updateNessusDebian Local Security Checks
high
96079SUSE SLED12 / SLES12 Security Update : gd (SUSE-SU-2016:3211-1)NessusSuSE Local Security Checks
high
95776Debian DSA-3732-1 : php5 - security updateNessusDebian Local Security Checks
critical
95725Slackware 14.0 / 14.1 / 14.2 / current : php (SSA:2016-347-03)NessusSlackware Local Security Checks
critical
94956PHP 7.0.x < 7.0.13 Multiple VulnerabilitiesNessusCGI abuses
high
94955PHP 5.6.x < 5.6.28 Multiple VulnerabilitiesNessusCGI abuses
high