CVE-2016-9901

HIGH

Description

HTML tags received from the Pocket server will be processed without sanitization and any JavaScript code executed will be run in the "about:pocket-saved" (unprivileged) page, giving it access to Pocket's messaging API through HTML injection. This vulnerability affects Firefox ESR < 45.6 and Firefox < 50.1.

References

http://rhn.redhat.com/errata/RHSA-2016-2946.html

http://rhn.redhat.com/errata/RHSA-2016-2973.html

http://www.securityfocus.com/bid/94885

http://www.securitytracker.com/id/1037461

https://bugzilla.mozilla.org/show_bug.cgi?id=1320057

https://security.gentoo.org/glsa/201701-15

https://www.mozilla.org/security/advisories/mfsa2016-94/

https://www.mozilla.org/security/advisories/mfsa2016-95/

Details

Source: MITRE

Published: 2018-06-11

Updated: 2018-08-01

Type: CWE-20

Risk Information

CVSS v2.0

Base Score: 7.5

Vector: (AV:N/AC:L/Au:N/C:P/I:P/A:P)

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL